1.5 port mirroring
SW3
No monitor session all
Interface  range  f0/1 – 8 , f0/11 , port-chanel 13
No shut down
exit
monitor session 1 source interface f0/1 – 8 , port-channel 13 both monitor session 1 destination interface f0/11
2.3 implement ipv4 BGP
SW1
router bgp yy
no syn
no au
bgp 7.7
2.2 remote-as yy
2.2 update-source lo 0
3.3 remote-as yy
3.3 update-source lo 0
8.8 remote-as yy
8.8 update-source lo 0
nei 254 remote-as 254
exit
R2
router bgp yy
no syn
no au
bgp 2.2
3.3 remote-as yy
3.3 update-source lo 0
7.7 remote-as yy
7.7 update-source lo 0
8.8 remote-as yy
8.8 update-source lo 0
8.8 weight 100
exit Sw2
router bgp yy
no syn
no au
bgp 8.8
2.2 remote-as yy
2.2 update-source lo 0
3.3 remote-as yy
3.3 update-source lo 0
7.7 remote-as yy
7.7 update-source lo 0
nei 254 remote-as 254
nei 254 route-map aspath in exit
route-map aspath permit 10
set as-path prepend 253
exit
R3
router bgp yy
no syn
no au
bgp 3.3
2.2 remote-as yy
2.2 update-source lo 0
7.7 remote-as yy
7.7 update-source lo 0
8.8 remote-as yy
8.8 update-source lo 0
7.7 weight 100
exit
2.4 Implement MPLS layer 3 VPNs
需求1 R1&R2
R4
ip cef
mpls ip
mpls ldp router-id f0/1 force
mpls label protocol ldp
ip vrf vpnyy
rd 100:1
route-target export 100:1
route-target import 100:1
int f0/0
ip vrf forwarding vpnyy
ip 128.130 255.255.255.224
no sh
exit
int f0/1
mpls ip
no sh
exit
router ospf yy vrf vpnyy
<4.4
<128.130 0.0.0.0 area 1
redistribute bgp 100 subnets
exit
router bgp 100
no bgp default ipv4-unicast(禁止IPV4BGP单播)
bgp 4.4
<5.5 remote-as 100
<5.5 update-source lo 0
address-family vpnv4
<5.5 activate
<5.5 send-community extended
exit-address-family
address-family ipv4 vrf vpn yy
redistribute connected
redistribute ospf yy vrf vpnyy match internal external 1 external 2 no syn
exit-address-family R5
ip cef
mpls ip
mpls ldp router-id f0/0 force
mpls label protocol ldp
ip vrf vpnyy
rd 100:1
route-target export 100:1
route-target import 100:1
int f0/1
ip vrf forwarding vpnyy
ip 0.130 255.255.255.224
exit
int f0/0
mpls ip
exit
router ospf yy vrf vpnyy
5.5
0.130 0.0.0.0 area 51
redistribute bgp 100 subnets
exit
router bgp 100
no bgp default ipv4-unicast
bgp 5.5
<4.4 remote-as 100
<4.4 update-source lo 0
address-family vpnv4
<4.4 activate
<4.4 send-community extended
exit-address-family
address-family ipv4 vrf vpnyy
redistribute connected
redistribute ospf yy vrf vpnyy match internal external 1 external 2 no syn
exit-address-family
配置SW1---R5之间的VIRTUAL-LINK: SW1
router ospf yy
area 51 5.5
exit
R5
router ospf yy vrf vpnyy
area 51 7.7
exit
配置R4---R5之间的SHAM-Link:
R4
int lo 100
ip vrf forwarding vpnyy
ip 100.4 255.255.255.255 no sh
exit
router ospf yy vrf vpnyy
area 0 100.100.5 exit
R5
int lo 100
ip vrf forwarding vpnyy
ip 100.5 255.255.255.255 no sh
exit
router ospf yy vrf vpnyy
area 0 100.100.4 exit 2.5 implement ipv6
2.5.1 implement ipv6 addressing
SW3:
sw3(config)# sdm prefer ipv4-ipv6-dual default sw3(config)# ipv6 unicast-routing
sw3(config)# int vlan 33
sw3(config-if)#ipv6 address 20yy:1010:222::9/64 sw3(config-if)#exit
sw3(config)#int vlan 234
sw3(config-if)ipv6 address 20yy:1010:10::9/64 sw3(config-if)exit
R2:
R2(config)#ipv6 unicast-routing
R2(config)#int g0/1
R2(config-if)#ipv6 address 20yy:1010:10::2/64
R2(config-if)#exit
R2(config)#int g0/0
R2(config-if)#ipv6 address 20yy:1010:20:2/64
R2(config-if)#exit
2.5.2 implement ipv6 routing
sw3:
sw3(config)#ipv6 router rip cisco
sw3(config)#int vlan 234
sw3(config-if)#ipv6 rip cisco enable
sw3(config-if)#ipv6 rip cisco default-information originate SW3(config-if)#exit
sw3(config)#interface vlan 33
sw3(config-if)#ipv6 rip cisco enable
sw3(config-if)#exit
R2:
R2(config)#ipv6 router rip cisco
R2(config)#int g0/0
R2(config-if)#ipv6 rip cisco enable
R2(config-if)#exit
R2(config)#int g0/1
R2(config-if)#ipv6 rip cisco enable
R2(config-if)#exit 3.1 implement PIM-SM
SW2
ip multicast-routing distribute
ip pim autorp listener
int vlan 243
ip pim sparse-mode
ip igmp join-group 239.10.5.1
exit
SW3
ip multicast-routing distribute
ip pim autorp listener
ip pim send-rp-announce lo 0 scope 15 group-list PERMIT_G ip access-list standard PERMIT_G
permit 239.10.5.0 0.0.0.255
exit
int vlan 243
ip pim sparse-mode
exit
int vlan 234
ip pim sparse-mode
exit
int lo 0
ip pim sparse-mode
exit
sw4
ip multicast-routing distribute
ip pim autorp listener
ip pim send-rp-discovery lo 0 scope 15
int vlan 234
ip pim sparse-mode
exit
int vlan 243
ip pim sparse-mode
exit
int lo 0
ip pim sparse-mode
exit
3.2 implement IGMP Group
sw2/sw3/sw4
access-list 1 permit host 239.10.5.1
int vlan 243
ip igmp access-group 1
exit 4.3 Link Fragmentation and interleaving
4.3.1 LFI
R1:
R1(config)#multilink bundle-name endpoint
R1(config)#int multilink 1
R1(config-if)#ban 128
R1(config-if)#ppp multilink interleave
R1(config-if)#ppp multilink fragment delay 8
R1(config-if)#exit
R1(config)#map-class frame-relay CIR
R1(config-map-class)#frame-relay cir 128000
R1(config-map-class)#frame-relay bc 8000
R1(config-map-class)#frame-relay be 1000
R1(config-map-class)#exit
R1(config)#int s0/1
R1(config-if)#frame-relay traffic-shaping
R1(config-if)#exit
R1(config)#int s0/1.13 point-to-point
R1(config-subif)#bandwidth 128
R1(config-subif)#frame-relay int dlci 221 ppp virtual-template 1 R1(config-fr-dlci)#class CIR
R1(config-fr-dlci)#end
R3:
R3(config)#multilink bundle-name endpoint
R3(config)#int multilink 1
R3(config-if)#bandwidth 128
R3(config-if)#ppp multilink interleave
R3(config-if)#ppp multilink fragment delay 8
R3(config-if)#no sh
R3(config-if)#exit
R3(config)#map-class frame-relay CIR
R3(config-map-class)#frame-relay cir 128000
R3(config-map-class)#frame-relay bc 8000
react routerv6R3(config-map-class)#frame-relay be 1000
R3(config-map-class)#exit
R3(config)#int s2/0
R3(config-if)#frame-relay traffic-shaping
R3(config-if)#exit
R3(config)#int s2/0.13 point-to-point
R3(config-subif)#bandwidth 128
R3(config-subif)#f rame-relay int dlci 223 ppp virtual-template 1 R3(config-fr-dlci)#class CIR
R3(config-fr-dlci)#exit